Email System Status
Resolved
Oct 26 at 10:22am PDT
Our email systems are now fully operational. Both transactional and marketing emails (broadcasts + automations) have been restored and are functioning normally.
The issue occurred after the system exceeded a sending threshold. We’ve implemented scalability improvements to better handle increased sending volumes and prevent future disruptions.
We recommend resending any broadcasts or automations that were scheduled to send earlier today to ensure delivery.
Thank you for your patience while we worked to resolve this issue.
Affected services
Updated
Oct 26 at 07:38am PDT
We’re continuing to work on a solution to restore marketing emails (broadcasts + automations). Our engineering team is focused on improving scalability to support higher sending volumes.
In the meantime, we advise against sending marketing emails until the issue is fully resolved.
We expect a full resolution this afternoon and will provide another update once everything is back online.
Affected services
Created
Oct 26 at 05:22am PDT
Issue Summary:
Between 1:30 AM ET and 8:00 AM ET on Sunday, October 26, our email system experienced an outage after exceeding a sending threshold.
Current Status:
Transactional emails are now fully operational.
Marketing emails (broadcasts + automations) remain paused as our team works on improving scalability to better support the current sending volume.
Next Steps:
We’re actively implementing infrastructure improvements today to prevent similar issues and ensure our systems can handle future growth in email sending. We’ll share another update once marketing emails are back online.
Affected services