Back to overview
Degraded

API Performance Degradation

Dec 23 at 09:34am PST
Affected services
Dashboard (dashboard.arketa.com)
Booking pages
Widget API
Widget API v2

Resolved
Dec 23 at 10:42am PST

Earlier today, we experienced API slowdowns due to increased load. The root cause was a newly released feature intended to speed up reservation-related network requests. Under load, this feature caused one of our caching services to become overloaded, which led to excessive request retries and pushed our main server to capacity.

To resolve the issue, we upgraded the caching service to handle the increased demand and scaled our main server capacity to better absorb retries. Performance is now recovering and services are returning to normal. We’ll continue monitoring closely.

Created
Dec 23 at 09:34am PST

Our API is currently at capacity, which may result in slow loading times. We’re actively working on an update and will share more information shortly.